Ably Javascript & Node.js release 1.0.17

Client library release:

https://github.com/ably/ably-js/releases/tag/1.0.17

Release:

  • Give presence.subscribe attach callback the same behaviour as channel.subscribe, for consistency (so it calls back once attached rather than only in the event of an attach error) #526
  • Handle empty string response from an authUrl or authCallback as a token error
  • Upgrade ws module to v5 (nodejs only) #525

Note: this release drops support for nodejs versions < 4.5. node v4 versions 4.5 or later are still supported; customers using node v4 are highly encouraged to update to the latest 4.x branch for security reasons